You are here:>>Need help with UART protocol
Need help with UART protocol 2022-09-27T01:49:09+00:00

Home Forums Advice Need help with UART protocol

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • David George-Kennedy
    Post count: 0

    Single Way Relay Module Delay Power-off Trigger Delay Cycle Timing Circuit Switch SKU:200350

    I am having the same problem as this I found on your site for this product but I can’t find the answer. My application requires I am able to use UART to change the timer settings.
    <div class=”col-sm-12 bg-primary wk-margin-bottom”>

    —————————————
    <p class=”lead wk-margin-bottom”>Help with UART control</p>
    <p class=”question_details”>I am unable to set the OP timer to four-digits using UART. Each time I try, the device reports “FAIL”. I can use the following commands successfully: OP:1 OP:11 OP:111 But all of the following commands “FAIL”. OP:1111 OP:111.1 OP:1.1.1.1 How do I get it to work? Do you have any examples? Thank you!</p>

    </div>
    <div class=”col-sm-11 pull-right bg-success wk-margin-bottom”>
    <p class=”wk-margin-top”>DROK <span class=”question_date”>answered [at] 2020-01-12 09:19:42</span></p>
    <p class=”question”>Hello We have received your message through Facebook, please check our response. Best regards.</p>

    </div>
     

    Drok
    Keymaster
    Post count: 2948

    Hello David George-Kennedy,

    Do you mean you can send OP:0001 OP:0011 OP:0111 . It is impossible to send  OP:1 OP:11 OP:111 directly.

    Could you please show us the screenshot abouth commands?

    David George-Kennedy
    Post count: 0

    I am unable to get the UART to work properly for the time commands.

    read – works

    PX – works

    OP:XXXX – works for X & XX & XXX, XXXX FAIL

    OP:XXX.X & XX.XX & X.X.X.X – FAIL

    on – FAIL

    off – FAIL

    I will follow up with a screenshot showing above. I need the OP:XX.XX and OP:X.X.X.X to work (unit always in P7 mode).

    David George-Kennedy
    Post count: 0

    I can’t attach the screen shot sorry.

    By the way, I have the same UART issue on blue and black versions of the timer.

    Drok
    Keymaster
    Post count: 2948

    Hello

    Please send picture to service@droking.com

    David George-Kennedy
    Post count: 0

    After the follow up via email (thanks DROK) it appears my problem was very simple to fix. Turn off CR+LF in the send settings – I had it duplicating receive which was set to CR+LF. Soon as that was turned off the timer took the UART commands as expected.

Viewing 6 posts - 1 through 6 (of 6 total)
Reply To: Need help with UART protocol
Your information: